{"action":"Upgrade go to 1.17.8-r0 or later.","affected":[{"fixed":"1.17.8-r0","introduced":"1.17"}],"component":"go","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["1.17.8-r0"],"id":"tcs_01M6HFHR8NWHGA2P18YVFRC35N","modified_at":"2026-11-03T07:30:15.100393484Z","published_at":"2022-03-05T20:15:08.323Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-24921","https://security.alpinelinux.org/vuln/CVE-2022-24921"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-24921#Alpine:v3.24/go","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-24921"}],"summary":"regexp.Compile in Go before 1.16.15 and 1.17.x before 1.17.8 allows stack exhaustion via a deeply nested expression."}