{"action":"Upgrade ruby-nokogiri to 1.13.4-r0 or later.","affected":[{"fixed":"1.13.4-r0","introduced":"0"}],"component":"ruby-nokogiri","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.21","exploited":false,"fixed_versions":["1.13.4-r0"],"id":"tcs_01M6HFHS64NQSANKYWNXYT7674","modified_at":"2026-11-03T07:30:15.297245775Z","published_at":"2022-04-11T22:15:07.347Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-24836","https://security.alpinelinux.org/vuln/CVE-2022-24836"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-24836#Alpine:v3.21/ruby-nokogiri","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-24836"}],"summary":"Nokogiri is an open source XML and HTML library for Ruby. Nokogiri `< v1.13.4` contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encodi"}