{"action":"Upgrade go to 1.18.4-r0 or later.","affected":[{"fixed":"1.18.4-r0","introduced":"1.18.0"}],"component":"go","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["1.18.4-r0"],"id":"tcs_01M6HFJ7ZTTS91FZ2V3HJPDT18","modified_at":"2026-11-03T07:30:16.501131041Z","published_at":"2022-08-10T20:15:26.250Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-1962","https://security.alpinelinux.org/vuln/CVE-2022-1962"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-1962#Alpine:v3.23/go","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-1962"}],"summary":"Uncontrolled recursion in the Parse functions in go/parser before Go 1.17.12 and Go 1.18.4 allow an attacker to cause a panic due to stack exhaustion via deeply nested types or declarations."}