{"action":"Upgrade py3-joblib to 1.2.0-r0 or later.","affected":[{"fixed":"1.2.0-r0","introduced":"0"}],"component":"py3-joblib","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["1.2.0-r0"],"id":"tcs_01M6HFMSB9HTN3E33FMC0PTM76","modified_at":"2026-11-03T07:30:18.713657373Z","published_at":"2022-09-26T05:15:10.427Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-21797","https://security.alpinelinux.org/vuln/CVE-2022-21797"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-21797#Alpine:v3.19/py3-joblib","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-21797"}],"summary":"The package joblib from 0 and before 1.2.0 are vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement."}