{"action":"Upgrade pdns to 4.6.1-r0 or later.","affected":[{"fixed":"4.6.1-r0","introduced":"0"}],"component":"pdns","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.16","exploited":false,"fixed_versions":["4.6.1-r0"],"id":"tcs_01M6HGKX7FMCTB0R3NP62TQHJZ","modified_at":"2026-11-03T07:30:35.100153205Z","published_at":"2022-03-25T15:15:07.697Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-27227","https://security.alpinelinux.org/vuln/CVE-2022-27227"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-27227#Alpine:v3.16/pdns","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-27227"}],"summary":"In PowerDNS Authoritative Server before 4.4.3, 4.5.x before 4.5.4, and 4.6.x before 4.6.1 and PowerDNS Recursor before 4.4.8, 4.5.x before 4.5.8, and 4.6.x before 4.6.1, insufficient validation of an"}