{"action":"Upgrade go to 1.18.4-r0 or later.","affected":[{"fixed":"1.18.4-r0","introduced":"1.18.0"}],"component":"go","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["1.18.4-r0"],"id":"tcs_01M6HGMBRKAV86MD5SSWSD036N","modified_at":"2026-11-03T07:30:36.206794812Z","published_at":"2022-08-10T20:15:32.767Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-28131","https://security.alpinelinux.org/vuln/CVE-2022-28131"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-28131#Alpine:v3.19/go","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-28131"}],"summary":"Uncontrolled recursion in Decoder.Skip in encoding/xml before Go 1.17.12 and Go 1.18.4 allows an attacker to cause a panic due to stack exhaustion via a deeply nested XML document."}