{"action":"Upgrade go to 1.18.4-r0 or later.","affected":[{"fixed":"1.18.4-r0","introduced":"1.18.0"}],"component":"go","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.18","exploited":false,"fixed_versions":["1.18.4-r0"],"id":"tcs_01M6HH75ARD8Q8R99W3M2FN36T","modified_at":"2026-11-03T07:30:50.324853691Z","published_at":"2022-08-10T20:15:42.640Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-30635","https://security.alpinelinux.org/vuln/CVE-2022-30635"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-30635#Alpine:v3.18/go","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-30635"}],"summary":"Uncontrolled recursion in Decoder.Decode in encoding/gob before Go 1.17.12 and Go 1.18.4 allows an attacker to cause a panic due to stack exhaustion via a message which contains deeply nested structur"}