{"action":"Upgrade grafana to 9.0.3-r0 or later.","affected":[{"fixed":"9.0.3-r0","introduced":"8.0.0"}],"component":"grafana","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.17","exploited":false,"fixed_versions":["9.0.3-r0"],"id":"tcs_01M6HH7PS8M6CF1WWFSH3DJ6PN","modified_at":"2026-11-03T07:30:52.037723936Z","published_at":"2022-07-15T12:15:08.903Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-31097","https://security.alpinelinux.org/vuln/CVE-2022-31097"],"severity":{"label":"high","score":8.7},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-31097#Alpine:v3.17/grafana","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-31097"}],"summary":"Grafana is an open-source platform for monitoring and observability. Versions on the 8.x and 9.x branch prior to 9.0.3, 8.5.9, 8.4.10, and 8.3.10 are vulnerable to stored cross-site scripting via the"}