{"action":"Upgrade php7 to 7.4.32-r0 or later.","affected":[{"fixed":"7.4.32-r0","introduced":"0"}],"component":"php7","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.15","exploited":false,"fixed_versions":["7.4.32-r0"],"id":"tcs_01M6HH7SPS6YE7ZPNAGAFAKNWF","modified_at":"2026-11-03T07:30:52.192194329Z","published_at":"2022-06-16T06:15:08.623Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-31625","https://security.alpinelinux.org/vuln/CVE-2022-31625"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-31625#Alpine:v3.15/php7","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-31625"}],"summary":"In PHP versions 7.4.x below 7.4.30, 8.0.x below 8.0.20, and 8.1.x below 8.1.7, when using Postgres database extension, supplying invalid parameters to the parametrized query may lead to PHP attempting"}