{"action":"Upgrade emacs to 28.2-r3 or later.","affected":[{"fixed":"28.2-r3","introduced":"0"}],"component":"emacs","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.20","exploited":false,"fixed_versions":["28.2-r3"],"id":"tcs_01M6HH89WPVMAZ471WH3V10N7H","modified_at":"2026-11-03T07:30:52.984713497Z","published_at":"2022-11-28T06:15:10.563Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-45939","https://security.alpinelinux.org/vuln/CVE-2022-45939"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-45939#Alpine:v3.20/emacs","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-45939"}],"summary":"GNU Emacs through 28.2 allows attackers to execute commands via shell metacharacters in the name of a source-code file, because lib-src/etags.c uses the system C library function in its implementation"}