{"action":"Upgrade go to 1.18.5-r0 or later.","affected":[{"fixed":"1.18.5-r0","introduced":"1.18.0"}],"component":"go","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["1.18.5-r0"],"id":"tcs_01M6HJDMP7SESBV2KQTJAYFCCE","modified_at":"2026-11-03T07:31:17.036564018Z","published_at":"2022-08-10T20:15:47.507Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-32189","https://security.alpinelinux.org/vuln/CVE-2022-32189"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-32189#Alpine:v3.22/go","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-32189"}],"summary":"A too-short encoded message can cause a panic in Float.GobDecode and Rat GobDecode in math/big in Go before 1.17.13 and 1.18.5, potentially allowing a denial of service."}