{"action":"Upgrade libreswan to 4.6-r0 or later.","affected":[{"fixed":"4.6-r0","introduced":"4.2"}],"component":"libreswan","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["4.6-r0"],"id":"tcs_01M6HJF1HSRAZ36K1JZ330TWVD","modified_at":"2026-11-03T07:31:20.294667926Z","published_at":"2022-01-15T02:15:06.547Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-23094","https://security.alpinelinux.org/vuln/CVE-2022-23094"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-23094#Alpine:v3.24/libreswan","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-23094"}],"summary":"Libreswan 4.2 through 4.5 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted IKEv1 packet because pluto/ikev1.c wrongly expects that a state"}