{"action":"Upgrade njs to 0.7.3-r0 or later.","affected":[{"fixed":"0.7.3-r0","introduced":"0"}],"component":"njs","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.17","exploited":false,"fixed_versions":["0.7.3-r0"],"id":"tcs_01M6HJX5BGYSHMQ0AX1NFAJV9F","modified_at":"2026-11-03T07:31:22.038827669Z","published_at":"2022-02-14T22:15:08.317Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-25139","https://security.alpinelinux.org/vuln/CVE-2022-25139"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-25139#Alpine:v3.17/njs","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-25139"}],"summary":"njs through 0.7.0, used in NGINX, was discovered to contain a heap use-after-free in njs_await_fulfilled."}