{"action":"Upgrade ruby-nokogiri to 1.13.6-r0 or later.","affected":[{"fixed":"1.13.6-r0","introduced":"0"}],"component":"ruby-nokogiri","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.17","exploited":false,"fixed_versions":["1.13.6-r0"],"id":"tcs_01M6HJYG3MDR7CSMTY5KVYSV20","modified_at":"2026-11-03T07:31:25.655944728Z","published_at":"2022-05-20T19:15:08.203Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-29181","https://security.alpinelinux.org/vuln/CVE-2022-29181"],"severity":{"label":"high","score":8.2},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-29181#Alpine:v3.17/ruby-nokogiri","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-29181"}],"summary":"Nokogiri is an open source XML and HTML library for Ruby. Nokogiri prior to version 1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers, allowing specially crafted untrusted input"}