{"action":"Upgrade nodejs-current to 18.9.1-r0 or later.","affected":[{"fixed":"18.9.1-r0","introduced":"0"}],"component":"nodejs-current","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["18.9.1-r0"],"id":"tcs_01M6HJZAV413038V39HJ70Y3AS","modified_at":"2026-11-03T07:31:25.815299186Z","published_at":"2022-07-14T15:15:08.387Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-32215","https://security.alpinelinux.org/vuln/CVE-2022-32215"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-32215#Alpine:v3.19/nodejs-current","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-32215"}],"summary":"The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not correctly handle multi-line Transfer-Encoding headers. This can lead to HTTP Request Smuggling (HRS)."}