{"action":"Upgrade nodejs-current to 18.6.0-r0 or later.","affected":[{"fixed":"18.6.0-r0","introduced":"0"}],"component":"nodejs-current","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["18.6.0-r0"],"id":"tcs_01M6HJZEWHT35TJ1TR64VECD23","modified_at":"2026-11-03T07:31:25.817693762Z","published_at":"2022-07-14T15:15:08.237Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-32212","https://security.alpinelinux.org/vuln/CVE-2022-32212"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-32212#Alpine:v3.23/nodejs-current","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-32212"}],"summary":"A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly"}