{"action":"Upgrade nodejs-current to 18.6.0-r0 or later.","affected":[{"fixed":"18.6.0-r0","introduced":"0"}],"component":"nodejs-current","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.17","exploited":false,"fixed_versions":["18.6.0-r0"],"id":"tcs_01M6HJZMN5HDMEFC0FFR93V98M","modified_at":"2026-11-03T07:31:25.823159679Z","published_at":"2022-07-14T15:15:08.337Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-32214","https://security.alpinelinux.org/vuln/CVE-2022-32214"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-32214#Alpine:v3.17/nodejs-current","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-32214"}],"summary":"The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP requests. This can lead to HTTP Request Smuggling (HRS)."}