{"action":"Upgrade wolfssl to 5.5.3-r0 or later.","affected":[{"fixed":"5.5.3-r0","introduced":"0"}],"component":"wolfssl","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["5.5.3-r0"],"id":"tcs_01M6HKG2T37KTEK83SFXQ0R3JB","modified_at":"2026-11-03T07:31:26.101774207Z","published_at":"2022-11-07T00:15:09.643Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2022-42905","https://security.alpinelinux.org/vuln/CVE-2022-42905"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2022-42905#Alpine:v3.19/wolfssl","url":"https://osv.dev/vulnerability/ALPINE-CVE-2022-42905"}],"summary":"In wolfSSL before 5.5.2, if callback functions are enabled (via the WOLFSSL_CALLBACKS flag), then a malicious TLS 1.3 client or network attacker can trigger a buffer over-read on the heap of 5 bytes."}