PyPI/poetry CVE-2026-34591: medium 6.5, EPSS 0.47%
Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write
Action: Upgrade poetry to 2.3.3 or later.
pip install poetry==2.3.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.4.0 | 2.3.3 | - |
Fixed versions
| 2.3.3 |
Sources
- osv: GHSA-2599-h6xx-hpxp
- https://github.com/python-poetry/poetry/security/advisories/GHSA-2599-h6xx-hpxp
- https://nvd.nist.gov/vuln/detail/CVE-2026-34591
- https://github.com/python-poetry/poetry/pull/10792
- https://github.com/python-poetry/poetry
- https://github.com/python-poetry/poetry/releases/tag/2.3.3
- http://github.com/python-poetry/poetry/commit/ed59537ac3709cfbdbf95d957de801c13872991a
CVE-2026-34591 · published · modified · JSON