PyPI/flask-appbuilder CVE-2022-31177: low 2.7, EPSS 0.77%
Flask-AppBuilder before v4.1.3 allows inference of sensitive information through query strings
Action: Upgrade flask-appbuilder to 4.1.3 or later.
pip install flask-appbuilder==4.1.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.1.3 | - |
Fixed versions
| 4.1.3 |
Sources
- osv: GHSA-32ff-4g79-vgfc
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-32ff-4g79-vgfc
- https://nvd.nist.gov/vuln/detail/CVE-2022-31177
- https://github.com/dpgaspar/Flask-AppBuilder
- https://github.com/dpgaspar/Flask-AppBuilder/releases/tag/v4.1.3
- https://github.com/pypa/advisory-database/tree/main/vulns/flask-appbuilder/PYSEC-2022-247.yaml
CVE-2022-31177 · published · modified · JSON