PyPI/ansible CVE-2020-10691: medium 5.2, EPSS 0.30%
Path Traversal in Ansible
Action: Upgrade ansible to 2.9.7 or later.
pip install ansible==2.9.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.9.0a1 | 2.9.7 | - |
Fixed versions
| 2.9.7 |
Sources
- osv: GHSA-3c67-gc48-983w
- https://nvd.nist.gov/vuln/detail/CVE-2020-10691
- https://github.com/ansible/ansible/pull/68596
- https://github.com/ansible/ansible/commit/b2551bb6943eec078066aa3a923e0bb3ed85abe8
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10691
- https://github.com/advisories/GHSA-3c67-gc48-983w
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-2.yaml
CVE-2020-10691 · published · modified · JSON