PyPI/tensorflow CVE-2021-41216: medium 5.5, EPSS 0.16%
Heap buffer overflow in `Transpose`
Action: Upgrade tensorflow to 2.4.4 or later.
pip install tensorflow==2.6.1pip install tensorflow==2.5.2pip install tensorflow==2.4.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.6.0 | 2.6.1 | - |
| 2.5.0 | 2.5.2 | - |
| 0 | 2.4.4 | - |
Fixed versions
| 2.6.1 | 2.5.2 | 2.4.4 |
Sources
- osv: GHSA-3ff2-r28g-w7h9
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-3ff2-r28g-w7h9
- https://nvd.nist.gov/vuln/detail/CVE-2021-41216
- https://github.com/tensorflow/tensorflow/commit/c79ba87153ee343401dbe9d1954d7f79e521eb14
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-625.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-823.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-408.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/blob/8d72537c6abf5a44103b57b9c2e22c14f5f49698/tensorflow/core/ops/array_ops.cc#L121-L185
CVE-2021-41216 · published · modified · JSON