PyPI/tensorflow CVE-2021-41228: high 7.5, EPSS 0.22%
Code injection in `saved_model_cli`
Action: Upgrade tensorflow to 2.4.4 or later.
pip install tensorflow==2.5.2pip install tensorflow==2.4.4pip install tensorflow==2.6.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.5.0 | 2.5.2 | - |
| 0 | 2.4.4 | - |
| 2.6.0 | 2.6.1 | - |
Fixed versions
| 2.5.2 | 2.4.4 | 2.6.1 |
Sources
- osv: GHSA-3rcw-9p9x-582v
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-3rcw-9p9x-582v
- https://nvd.nist.gov/vuln/detail/CVE-2021-41228
- https://github.com/tensorflow/tensorflow/commit/8b202f08d52e8206af2bdb2112a62fafbc546ec7
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-637.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-835.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-420.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-41228 · published · modified · JSON