PyPI/notebook CVE-2018-19351: medium 6.1, EPSS 1.51%
Jupyter Notebook XSS via untrusted notebooks
Action: Upgrade notebook to 5.7.1 or later.
pip install notebook==5.7.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 5.7.1 | - |
Fixed versions
| 5.7.1 |
Sources
- osv: GHSA-49qr-xh3w-h436
- https://nvd.nist.gov/vuln/detail/CVE-2018-19351
- https://github.com/jupyter/notebook/commit/107a89fce5f413fb5728c1c5d2c7788e1fb17491
- https://github.com/jupyter/notebook
- https://github.com/jupyter/notebook/blob/master/docs/source/changelog.rst
- https://github.com/pypa/advisory-database/tree/main/vulns/notebook/PYSEC-2018-17.yaml
- https://groups.google.com/forum/#!topic/jupyter/hWzu2BSsplY
- https://lists.debian.org/debian-lts-announce/2020/11/msg00033.html
- https://pypi.org/project/notebook/#history
CVE-2018-19351 · published · modified · JSON