PyPI/starlette CVE-2023-30798: high 7.5, EPSS 1.30%
MultipartParser denial of service with too many fields or files
Action: Upgrade starlette to 0.25.0 or later.
pip install starlette==0.25.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.25.0 | - |
Fixed versions
| 0.25.0 |
Sources
- osv: GHSA-74m5-2c7w-9w3x
- https://github.com/encode/starlette/security/advisories/GHSA-74m5-2c7w-9w3x
- https://nvd.nist.gov/vuln/detail/CVE-2023-30798
- https://github.com/encode/starlette/commit/8c74c2c8dba7030154f8af18e016136bea1938fa
- https://github.com/encode/starlette
- https://github.com/pypa/advisory-database/tree/main/vulns/starlette/PYSEC-2023-48.yaml
- https://vulncheck.com/advisories/starlette-multipartparser-dos
CVE-2023-30798 · published · modified · JSON