PyPI/ansible CVE-2020-10685: medium 5.5, EPSS 0.36%
Exposure of Resource to Wrong Sphere and Insecure Temporary File in Ansible
Action: Upgrade ansible to 2.7.17 or later.
pip install ansible==2.7.17pip install ansible==2.8.11pip install ansible==2.9.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.7.0a1 | 2.7.17 | - |
| 2.8.0a1 | 2.8.11 | - |
| 2.9.0a1 | 2.9.7 | - |
Fixed versions
| 2.7.17 | 2.8.11 | 2.9.7 |
Sources
- osv: GHSA-77g3-3j5w-64w4
- https://nvd.nist.gov/vuln/detail/CVE-2020-10685
- https://github.com/ansible/ansible/pull/68433
- https://github.com/ansible/ansible/commit/4e1fe80e681fa466626e9dea53efe6b0253ea1b2
- https://github.com/ansible/ansible/commit/51d2514753544a9d58cd7524e27e696b2c944fb5
- https://github.com/ansible/ansible/commit/e1273b6faf036ed84e4f4edee85b888a4e256aee
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10685
- https://github.com/advisories/GHSA-77g3-3j5w-64w4
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-1.yaml
- https://security.gentoo.org/glsa/202006-11
- https://www.debian.org/security/2021/dsa-4950
CVE-2020-10685 · published · modified · JSON