PyPI/ansible CVE-2020-14330: medium 5.5, EPSS 0.57%
Improper Output Neutralization and Improper Encoding or Escaping of Output for Logs in ansible
Action: Upgrade ansible to 2.10.0 or later.
pip install ansible==2.10.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.10.0 | - |
Fixed versions
| 2.10.0 |
Sources
- osv: GHSA-785x-qw4v-6872
- https://nvd.nist.gov/vuln/detail/CVE-2020-14330
- https://github.com/ansible/ansible/issues/68400
- https://github.com/ansible/ansible/pull/69653
- https://github.com/ansible/ansible/commit/e0f25a2b1f9e6c21f751ba0ed2dc2eee2152983e
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-14330
- https://github.com/advisories/GHSA-785x-qw4v-6872
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-3.yaml
- https://www.debian.org/security/2021/dsa-4950
CVE-2020-14330 · published · modified · JSON