PyPI/eve CVE-2018-8097: critical 9.8, EPSS 6.20%
Eve allows execution of arbitrary code
Action: Upgrade eve to 0.7.5 or later.
pip install eve==0.7.5Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.7.5 | - |
Fixed versions
| 0.7.5 |
Sources
- osv: GHSA-8jxq-75rw-fhj9
- https://nvd.nist.gov/vuln/detail/CVE-2018-8097
- https://github.com/pyeve/eve/issues/1101
- https://github.com/pyeve/eve/commit/f8f7019ffdf9b4e05faf95e1f04e204aa4c91f98
- https://github.com/advisories/GHSA-8jxq-75rw-fhj9
- https://github.com/pyeve/eve
- https://github.com/pypa/advisory-database/tree/main/vulns/eve/PYSEC-2018-8.yaml
CVE-2018-8097 · published · modified · JSON