PyPI/langchain CVE-2023-38896: critical 9.8, EPSS 1.84%
LangChain vulnerable to arbitrary code execution
Action: Upgrade langchain to 0.0.236 or later.
pip install langchain==0.0.236Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.236 | - |
Fixed versions
| 0.0.236 |
Sources
- osv: GHSA-92j5-3459-qgp4
- https://nvd.nist.gov/vuln/detail/CVE-2023-38896
- https://github.com/hwchase17/langchain/issues/5872
- https://github.com/hwchase17/langchain/pull/6003
- https://github.com/langchain-ai/langchain/commit/8ba9835b925473655914f63822775679e03ea137
- https://github.com/langchain-ai/langchain/commit/e294ba475a355feb95003ed8f1a2b99942509a9e
- https://github.com/langchain-ai/langchain
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-146.yaml
- https://twitter.com/llm_sec/status/1668711587287375876
CVE-2023-38896 · published · modified · JSON