PyPI/tensorflow-gpu CVE-2021-41218: medium 5.5, EPSS 0.13%
Integer division by 0 in `tf.raw_ops.AllToAll`
Action: Upgrade tensorflow-gpu to 2.4.4 or later.
pip install tensorflow-gpu==2.6.1pip install tensorflow-gpu==2.5.2pip install tensorflow-gpu==2.4.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.6.0 | 2.6.1 | - |
| 2.5.0 | 2.5.2 | - |
| 0 | 2.4.4 | - |
Fixed versions
| 2.6.1 | 2.5.2 | 2.4.4 |
Sources
- osv: GHSA-9crf-c6qr-r273#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9crf-c6qr-r273
- https://nvd.nist.gov/vuln/detail/CVE-2021-41218
- https://github.com/tensorflow/tensorflow/commit/a8ad3e5e79c75f36edb81e0ba3f3c0c5442aeddc
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-627.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-825.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-410.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-41218 · published · modified · JSON