PyPI/esphome CVE-2024-27287: medium 6.5, EPSS 0.68%
esphome vulnerable to stored Cross-site Scripting in edit configuration file API
Action: Upgrade esphome to 2024.2.2 or later.
pip install esphome==2024.2.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 2023.12.9 | 2024.2.2 | - |
Fixed versions
| 2024.2.2 |
Sources
- osv: GHSA-9p43-hj5j-96h5
- https://github.com/esphome/esphome/security/advisories/GHSA-9p43-hj5j-96h5
- https://github.com/esphome/esphome/commit/37d2b3c7977a4ccbec59726ca7549cb776661455
- https://github.com/esphome/esphome
CVE-2024-27287 · published · modified · JSON