tocsin

PyPI/jupyterhub CVE-2024-41942: high 7.2, EPSS 0.59%

JupyterHub has a privilege escalation vulnerability with the `admin:users` scope

Action: Upgrade jupyterhub to 4.1.6 or later.

pip install jupyterhub==4.1.6
pip install jupyterhub==5.1.0

Affected

introducedfixedlast affected
04.1.6-
5.0.05.1.0-

Fixed versions

4.1.65.1.0

Sources

CVE-2024-41942 · published · modified · JSON