tocsin

PyPI/vyper CVE-2024-24561: critical 9.8, EPSS 0.90%

Vyper's bounds check on built-in `slice()` function can be overflowed

Action: Upgrade vyper to 0.4.0 or later.

pip install vyper==0.4.0

Affected

introducedfixedlast affected
00.4.0-

Fixed versions

0.4.0

Sources

CVE-2024-24561 · published · modified · JSON