PyPI/requests CVE-2014-1829: medium 5.3, EPSS 2.20%
Exposure of Sensitive Information to an Unauthorized Actor in Requests
Action: Upgrade requests to 2.3.0 or later.
pip install requests==2.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.3.0 | - |
Fixed versions
| 2.3.0 |
Sources
- osv: GHSA-cfj3-7x9c-4p3h
- https://nvd.nist.gov/vuln/detail/CVE-2014-1829
- https://github.com/kennethreitz/requests/issues/1885
- https://github.com/psf/requests/issues/1885
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=733108
- https://github.com/advisories/GHSA-cfj3-7x9c-4p3h
- https://github.com/psf/requests
- https://github.com/pypa/advisory-database/tree/main/vulns/requests/PYSEC-2014-13.yaml
- https://web.archive.org/web/20150523055216/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2015:133/?name=MDVSA-2015:133
- http://advisories.mageia.org/MGASA-2014-0409.html
- http://www.debian.org/security/2015/dsa-3146
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:133
- http://www.ubuntu.com/usn/USN-2382-1
CVE-2014-1829 · published · modified · JSON