PyPI/untangle CVE-2022-31471: high 7.5, EPSS 1.70%
untangle vulnerable to Improper Restriction of XML External Entity Reference
Action: Upgrade untangle to 1.2.1 or later.
pip install untangle==1.2.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.2.1 | - |
Fixed versions
| 1.2.1 |
Sources
- osv: GHSA-f83q-2cp7-qrjg
- https://github.com/stchris/untangle/security/advisories/GHSA-f83q-2cp7-qrjg
- https://nvd.nist.gov/vuln/detail/CVE-2022-31471
- https://github.com/pypa/advisory-database/tree/main/vulns/untangle/PYSEC-2022-244.yaml
- https://github.com/stchris/untangle
- https://github.com/stchris/untangle/releases/tag/1.2.1
- https://jvn.jp/en/jp/JVN30454777
CVE-2022-31471 · published · modified · JSON