PyPI/tensorflow CVE-2018-8825: high 8.8, EPSS 0.74%
Improper Restriction of Operations within the Bounds of a Memory Buffer in Google TensorFlow
Action: Upgrade tensorflow to 1.7.1 or later.
pip install tensorflow==1.7.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.5.0 | 1.7.1 | - |
Fixed versions
| 1.7.1 |
Sources
- osv: GHSA-frxx-2m33-6wcr
- https://nvd.nist.gov/vuln/detail/CVE-2018-8825
- https://github.com/tensorflow/tensorflow/commit/41335abb46f80ca644b5738550daef6136ba5476
- https://github.com/tensorflow/tensorflow/commit/8badd11d875a826bd318ed439909d5c47a7fb811
- https://github.com/advisories/GHSA-frxx-2m33-6wcr
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-226.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-233.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-208.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-003.md
CVE-2018-8825 · published · modified · JSON