PyPI/arches CVE-2022-41892: high 8.6, EPSS 0.60%
Arches vulnerable to execution of arbitrary SQL
Action: Upgrade arches to 6.1.2 or later.
pip install arches==6.1.2pip install arches==6.2.1pip install arches==7.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 6.1.2 | - |
| 6.2.0 | 6.2.1 | - |
| 7.0.0 | 7.2.0 | - |
Fixed versions
| 6.1.2 | 6.2.1 | 7.2.0 |
Sources
- osv: GHSA-gmpq-xrxj-xh8m
- https://github.com/archesproject/arches/security/advisories/GHSA-gmpq-xrxj-xh8m
- https://nvd.nist.gov/vuln/detail/CVE-2022-41892
- https://github.com/archesproject/arches/commit/7ed53e23a616edf3301d95814d9d64de5e3072a9
- https://github.com/archesproject/arches
- https://github.com/pypa/advisory-database/tree/main/vulns/arches/PYSEC-2022-42985.yaml
- https://pypi.org/project/arches/6.1.2
- https://pypi.org/project/arches/7.2.0
- https://securitylab.github.com/advisories/GHSL-2022-070_GHSL-2022-072_Arches
CVE-2022-41892 · published · modified · JSON