PyPI/ansible CVE-2019-14904: high 7.3, EPSS 0.42%
OS Command Injection and Improper Input Validation in ansible
Action: Upgrade ansible to 2.7.16 or later.
pip install ansible==2.7.16pip install ansible==2.8.8pip install ansible==2.9.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.16 | - |
| 2.8.0a1 | 2.8.8 | - |
| 2.9.0a1 | 2.9.3 | - |
Fixed versions
| 2.7.16 | 2.8.8 | 2.9.3 |
Sources
- osv: GHSA-gwr8-5j83-483c
- https://nvd.nist.gov/vuln/detail/CVE-2019-14904
- https://github.com/ansible/ansible/pull/65686
- https://github.com/ansible/ansible/commit/589a415f887b6f2bb65cd07fe6b2e9d0a8156b69
- https://github.com/ansible/ansible/commit/6a86650109b8654f5898369e45d3857624edf907
- https://github.com/ansible/ansible/commit/a1b0f72c98b4b2afaab8aafa255e82c2075049c8
- https://bugzilla.redhat.com/show_bug.cgi?id=1776944
- https://github.com/advisories/GHSA-gwr8-5j83-483c
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-161.yaml
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
- https://www.debian.org/security/2021/dsa-4950
CVE-2019-14904 · published · modified · JSON