PyPI/vllm: medium 6.5
vLLM vulnerable to Denial of Service by abusing xgrammar cache
Action: Upgrade vllm to 0.8.4 or later.
pip install vllm==0.8.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.6.5 | 0.8.4 | - |
Fixed versions
| 0.8.4 |
Sources
- osv: GHSA-hf3c-wxg2-49q9
- https://github.com/mlc-ai/xgrammar/security/advisories/GHSA-389x-67px-mjg3
- https://github.com/vllm-project/vllm/security/advisories/GHSA-hf3c-wxg2-49q9
- https://github.com/vllm-project/vllm/pull/16283
- https://github.com/vllm-project/vllm/commit/cb84e45ac75b42ba6795145923e8eb323bb825ad
- https://github.com/vllm-project/vllm
published · modified · JSON