PyPI/matrix-synapse CVE-2022-31152: high 7.5, EPSS 1.20%
Denial of service due to incorrect application of event authorization rules
Action: Upgrade matrix-synapse to 1.62.0rc1 or later.
pip install matrix-synapse==1.62.0rc1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.62.0rc1 | - |
Fixed versions
| 1.62.0rc1 |
Sources
- osv: GHSA-jhjh-776m-4765
- https://github.com/matrix-org/synapse/security/advisories/GHSA-jhjh-776m-4765
- https://nvd.nist.gov/vuln/detail/CVE-2022-31152
- https://github.com/matrix-org/synapse/pull/13087
- https://github.com/matrix-org/synapse/pull/13088
- https://github.com/matrix-org/synapse/commit/d4b1c0d800eaa83c4d56a9cf17881ad362b9194b
- https://github.com/matrix-org/synapse/commit/e16ea87d0f8c4c30cad36f85488eb1f647e640b0
- https://github.com/matrix-org/synapse
- https://github.com/matrix-org/synapse/releases/tag/v1.62.0
- https://github.com/pypa/advisory-database/tree/main/vulns/matrix-synapse/PYSEC-2022-262.yaml
CVE-2022-31152 · published · modified · JSON