tocsin

PyPI/kafka-python CVE-2026-10142: high 7.5, EPSS 0.35%

kafka-python vulnerable to denial of service through an unvalidated protocol frame length

Action: Upgrade kafka-python to 2.3.2 or later.

pip install kafka-python==2.3.2

Affected

introducedfixedlast affected
02.3.2-

Fixed versions

2.3.2

Sources

CVE-2026-10142 · published · modified · JSON