tocsin

PyPI/langchain-text-splitters CVE-2025-6985: high 7.5, EPSS 0.51%

LangChain Text Splitters is vulnerable to XML External Entity (XXE) attacks due to unsafe XSLT parsing

Action: Upgrade langchain-text-splitters to 0.3.9 or later.

pip install langchain-text-splitters==0.3.9

Affected

introducedfixedlast affected
00.3.9-

Fixed versions

0.3.9

Sources

CVE-2025-6985 · published · modified · JSON