tocsin

PyPI/langchain-core CVE-2026-44843: high 8.2, EPSS 0.41%

LangChain vulnerable to unsafe deserialization of attacker-controlled objects through overly broad `load()` allowlists

Action: Upgrade langchain-core to 0.3.85 or later.

pip install langchain-core==1.3.3
pip install langchain-core==0.3.85

Affected

introducedfixedlast affected
1.0.01.3.3-
00.3.85-

Fixed versions

1.3.30.3.85

Sources

CVE-2026-44843 · published · modified · JSON