PyPI/tweepy CVE-2012-5825: medium 5.3, EPSS 0.61%
Tweepy does not verify SSL Certificate
Action: Upgrade tweepy to 3.0 or later.
pip install tweepy==3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.0 | - |
Fixed versions
| 3.0 |
Sources
- osv: GHSA-pwx5-xg7g-wpc5
- https://nvd.nist.gov/vuln/detail/CVE-2012-5825
- https://github.com/tweepy/tweepy/issues/279
- https://github.com/tweepy/tweepy/pull/400
- https://exchange.xforce.ibmcloud.com/vulnerabilities/79831
- https://github.com/pypa/advisory-database/tree/main/vulns/tweepy/PYSEC-2012-17.yaml
- https://github.com/tweepy/tweepy
- http://www.cs.utexas.edu/~shmat/shmat_ccs12.pdf
CVE-2012-5825 · published · modified · JSON