PyPI/salt CVE-2019-17361: critical 9.8, EPSS 15.16%
SaltStack Salt is vulnerable to command injection
Action: Upgrade salt to 2019.2.3 or later.
pip install salt==2019.2.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2019.2.3 | - |
Fixed versions
| 2019.2.3 |
Sources
- osv: GHSA-q53j-p6r2-g2v4
- https://nvd.nist.gov/vuln/detail/CVE-2019-17361
- https://docs.saltstack.com/en/latest/topics/releases/2019.2.3.html#security-fix
- https://github.com/pypa/advisory-database/tree/main/vulns/salt/PYSEC-2020-177.yaml
- https://github.com/saltstack/salt
- https://usn.ubuntu.com/4459-1
- https://www.debian.org/security/2020/dsa-4676
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00026.html
CVE-2019-17361 · published · modified · JSON