PyPI/py-cord CVE-2022-36024: high 7.5, EPSS 0.80%
Bots using py-cord as Discord API wrapper are vulnerable to shutdowns through remote code execution
Action: Upgrade py-cord to 2.0.1 or later.
pip install py-cord==2.0.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.0.0 | 2.0.1 | - |
Fixed versions
| 2.0.1 |
Sources
- osv: GHSA-qmhj-m29v-gvmr
- https://github.com/Pycord-Development/pycord/security/advisories/GHSA-qmhj-m29v-gvmr
- https://nvd.nist.gov/vuln/detail/CVE-2022-36024
- https://github.com/Pycord-Development/pycord/pull/1568
- https://github.com/Pycord-Development/pycord
- https://github.com/pypa/advisory-database/tree/main/vulns/py-cord/PYSEC-2022-43146.yaml
CVE-2022-36024 · published · modified · JSON