PyPI/tensorflow CVE-2018-7577: high 8.1, EPSS 0.52%
Improper Input Validation in Google TensorFlow
Action: Upgrade tensorflow to 1.7.1 or later.
pip install tensorflow==1.7.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.1.0 | 1.7.1 | - |
Fixed versions
| 1.7.1 |
Sources
- osv: GHSA-qx2v-j445-g354
- https://nvd.nist.gov/vuln/detail/CVE-2018-7577
- https://github.com/tensorflow/tensorflow/commit/dfa9921e6343727b05f42f8d4a918b19528ff994
- https://github.com/advisories/GHSA-qx2v-j445-g354
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-225.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-232.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-207.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-005.md
CVE-2018-7577 · published · modified · JSON