PyPI/ansible CVE-2020-10729: medium 5, EPSS 0.43%
Insufficiently random values in Ansible
Action: Upgrade ansible to 2.9.6 or later.
pip install ansible==2.9.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.9.6 | - |
Fixed versions
| 2.9.6 |
Sources
- osv: GHSA-r6h7-5pq2-j77h
- https://nvd.nist.gov/vuln/detail/CVE-2020-10729
- https://github.com/ansible/ansible/issues/34144
- https://github.com/ansible/ansible/pull/67429
- https://github.com/ansible/ansible/commit/c520d70bf4748c8ee6718a7d0d0254051ba1c2e9
- https://bugzilla.redhat.com/show_bug.cgi?id=1831089
- https://github.com/advisories/GHSA-r6h7-5pq2-j77h
- https://github.com/ansible/ansible
- https://github.com/ansible/ansible/blob/v2.9.6/changelogs/CHANGELOG-v2.9.rst
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2021-105.yaml
- https://www.debian.org/security/2021/dsa-4950
CVE-2020-10729 · published · modified · JSON