PyPI/geonode CVE-2023-40017: high 7.5, EPSS 0.76%
GeoNode Server Side Request forgery
Action: Upgrade geonode to 4.2.0 or later.
pip install geonode==4.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.2.0 | 4.2.0 | - |
Fixed versions
| 4.2.0 |
Sources
- osv: GHSA-rmxg-6qqf-x8mr
- https://github.com/GeoNode/geonode/security/advisories/GHSA-rmxg-6qqf-x8mr
- https://nvd.nist.gov/vuln/detail/CVE-2023-40017
- https://github.com/GeoNode/geonode/commit/a9eebae80cb362009660a1fd49e105e7cdb499b9
- https://github.com/GeoNode/geonode
- https://github.com/pypa/advisory-database/tree/main/vulns/geonode/PYSEC-2023-269.yaml
CVE-2023-40017 · published · modified · JSON