PyPI/tensorflow-cpu CVE-2021-29577: low 2.5, EPSS 0.21%
Heap buffer overflow in `AvgPool3DGrad`
Action: Upgrade tensorflow-cpu to 2.1.4 or later.
pip install tensorflow-cpu==2.1.4pip install tensorflow-cpu==2.2.3pip install tensorflow-cpu==2.3.3pip install tensorflow-cpu==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: GHSA-v6r6-84gr-92rm#PyPI/tensorflow-cpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-v6r6-84gr-92rm
- https://nvd.nist.gov/vuln/detail/CVE-2021-29577
- https://github.com/tensorflow/tensorflow/commit/6fc9141f42f6a72180ecd24021c3e6b36165fe0d
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-505.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-703.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-214.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-29577 · published · modified · JSON